请选择 进入手机版 | 继续访问电脑版

雨林木风

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 58|回复: 0

Ubuntu 10.10安装ADS 2009 Update1

[复制链接]

6401

主题

6408

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
19613
发表于 2019-12-13 09:22:28 | 显示全部楼层 |阅读模式
  今天又把实验室电脑装会了Linux,现在已经是Ubuntu 10.10了。我对他的新特性关注不多,实验室电脑要的就是稳定稳定稳定,隔壁的服务器自从三年多前装上了RHEL 4就再也没重装过,cadence,ADS也什么问题没有。
  这次回来把NIS,NFS服务装了一遍,服务器换上了RHEL5。自己的小笔记本在另外一间连服务器,虽然外加了一个大屏幕,但是用起来还是很不舒服,所以搬过来实验室一台不用的服务器,装上Linux自己用。
  以前用过不少的发行版,大学刚一开始接触Linux的时候最喜欢干的事情就是装系统,几乎把所以能见到的系统装了一个遍,一开始是RedHat,redflag,后来是SUSE, Debain,装归装,但学到的东西不多,那时候就是什么也不懂,弄到最后实在不行就格盘重装了事。再后来读了研究生,每天都是在Linux上做设计,有一段时间把自己新买的小黑都装成了Ubuntu,大概用了半年的时间没装windows,真的是体会到现在的Linux和几年前我刚接触的时候的方便程度已经不能同日而语了。
  自己电脑要装Linux,一开始想的是装成和服务器一样的RHEL5,但装上之后才发现很不方便,每个东西都要网上找rpm,很是费劲,像是一下回到了解放前。后来想,还是在本机装Ubuntu吧,平时也用这个,就不和主机NIS了,灵活一点。
  装了新版的10.10,装ADS的时候问题就来了。先是java环境没有,这个简单,apt-get 一个JDK就行。可不想装好后还是不能运行,先是提示/bin/ksh没有,嗯,apt-get把ksh装上。装好后诡异的事就来了,明明环境都已经设好了,ads命令能运行,但老说agl***和hpeesofemx什么的找不到,可明明就在bin下啊,而且就算你到bin下面去直接运行这两个鬼东西他都说找不到。。。实在不知道是为什么。。找了很久,才看到这是64位机器的问题,终于在一个网页上找到解决办法,是少ia32的原因,原网页怎么也打不开了,baidu catch是这么说的:
  “这个问题是困惑了我很久,最近才找到问题所在。我的系统是Ubuntu server 64bit,之前在上面安装feition程序时,总是报错no such file or directory。但文件明明就在目录下,怎么会提示找不到文件呢,起初我考虑是不是sudo的环境变量的原因,用各种方式切换root用户还是提示no such file or directory。在网上搜索了很久也才找到原来是,需要安装ia32-libs。随后 aptitude install ia32-libs 搞定,fetion可以正常使用了。”
  装上之后又会说少libXm.so.3,这个装上openmotif就行,我装好了之后,还是提示我少这个东西。去/usr/lib64下面,/usr/lib下面看看都有,但去/usr/lib32下面看只有libXm.so.2,我明明是装的64位系统,不知道他为什么还会去32的lib下找?不知道。。建个软连接把libXm.so.2连接成libXm.so.3,终于能起来了。。。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

|appname
快速回复 返回顶部 返回列表